Merchants may receive emails originating from [email protected] warning of one or more failed transaction updates via webhook:
"Apexx webhook failed to post status updates for the below transactions on the webhook url configured in your organisation profile."
Example:
CAUSE
Merchants can request asynchronous transaction updates by specifying a URL in
- the configuration of a specific account, or
- in the webhook_transaction_update attribute of certain API requests.
If APEXX does not receive a HTTPS response with a status code of 200 (OK) from the merchant's endpoint, it will retry to send the transaction update up to 10 times. If no OK response has been received after the 10th attempt, a notification email will be sent to the email address associated with the originating organisation in APEXX.
SOLUTION
On receipt of the notification, merchants should investigate whether the endpoint accepting webhook is ready to accept incoming notifications
Any status information that did not update in the merchant system a result of the failed webhook should be manually updated
If the endpoint is set up at account level but needs updating or removing, please raise a support ticket with the relevant details of the change