PURPOSE
You receive a response with the message "Webhook URL should contain same domain as account webhook URL" when attempting to process a transaction.
CAUSE
The top level domain in the URL you are sending in the webhook_transaction_update field of the transaction request does not match a top level domain associated with the APEXX account used in the transaction.
SOLUTION
Verify that the transaction is posting to the intended account (by including the correct account ID or organisation ID plus currency code)
Ask APEXX Support to confirm the top level domains configured on the account
Ensure that the top level domains for webhook updates in API request and on the account match
RELATED ARTICLES
How can I process transactions in multiple currencies through the APEXX API?
What is the purpose of webhooks?