PURPOSE

As a merchant, you may wish to block API requests from being processed more than once if they are sent multiple times due to a fault or error. This is to prevent cardholders being charged or refunded twice in certain scenarios. 

 

CAUSE

The merchant application may resend an API request due to e.g. user error or if a response was not received in the expected timeframe from the API endpoint. 


SOLUTION

  • To activate this feature, include the duplicate_check parameter in the API request. Allowed values are true (do perform a duplicate check) and false (do not perform a duplicate check)

  • If the duplicate_check parameter is set to true then APEXX will check if the value in the unique reference field has been received previously in the past 24 hours. If the same request has already been received with the same unique reference value then APEXX will return the same response it returned to the original transaction

  • On receipt of the initial request, APEXX will wait for up to 120 seconds for a response from the acquirer. If a duplicate request is received before the acquirer's response has been received, APEXX will return a "duplicate request" response. 

  • This feature is currently available for the following API request types and reference fields:


API Request TypeReference field used in duplicate check

createCardTransaction

merchant_reference

captureCardTransaction

capture_reference

cancelCardTransaction

cancel_reference
refundCardTransactionmerchant_refund_reference


Note that

  • Echo responses will only be sent for transactions which have received a response from the PSP
  • Echo responses will not be sent for transactions with FAILED status



RELATED ARTICLES

APEXX API Documentation